What do you
think is the best practice to solve this issue : rename the
variable in dns_pac, include a modified version of icmp6.h with Bro... ?
The first question is whether the icmp6.h include really needs to be in
net_util.h, or if it could be confined to the source file(s) that use the
Actually I just need it in Sessions.cc (for the switch on the ICMP type)
so I will use the #undef solution : it's less ugly than keeping a
modified version of icmp6.h.
Thanks for your help !